Errors in AWS us-east-1 cloud space

Incident Report for Upbound

Resolved

AWS us-east-1 Cloud Space is back to operational
Posted Oct 20, 2025 - 18:14 UTC

Investigating

New pods are slow to provision due to an ongoing incident in AWS us-east-1
Posted Oct 20, 2025 - 14:06 UTC