Marketplace and xpkg.upbound.io offline

Incident Report for Upbound

Resolved

This incident has been resolved.
Posted Jul 20, 2026 - 06:56 UTC

Monitoring

We've rolled out a new build of the service that powers Marketplace and xpkg.upbound.io. The new build uses more aggressive caching, which appears to have allowed the retry request storm to subside.
Posted Jul 20, 2026 - 06:11 UTC

Identified

We're continuing to work on this issue. We're seeing a massive spike in xpkg.upbound.io traffic, most likely Crossplane control planes in a retry storm. We're attempting to absorb this traffic to return to normal serving. At present we're allowing ~10% of traffic through.
Posted Jul 20, 2026 - 03:24 UTC

Investigating

marketplace.upbound.io and xpkg.upbound.io is currently failing. We're investigating.
Posted Jul 20, 2026 - 00:24 UTC
This incident affected: Marketplace (Marketplace UI, Marketplace Registry).