Service Disruption: Customer Support Portal (External Vendor Incident)

Incident Report for Upbound

Resolved

This incident has been resolved.
Posted Nov 11, 2025 - 15:09 UTC

Monitoring

A fix has been rolled out and we are monitoring the situation.
Posted Nov 11, 2025 - 15:05 UTC

Update

The vendor has identified the issue and are working on deploying the fix to production.
Posted Nov 11, 2025 - 14:24 UTC

Identified

The issue has been reported to our vendor and we are waiting for resolution on their end. Currently, users are able to log in to the customer portal and view a list of issues that they've submitted. However, when you click on an issue, it currently shows "Sorry, we've encountered an error.". Customers are still able to send in support requests via support@upbound.io.
Posted Nov 11, 2025 - 10:05 UTC
This incident affected: Upbound (Customer Support).